Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда
27 сентября 2020 09:59
 
Список заданий
Бадах Евгений
Приватное сообщение

доработать конфигурацию 1С 8.2 Экспедирование

Санкт-Петербург(Россия )
rsg.spot
26.11.1986(33 года)
8 |  0
18 декабря 2019 в 20:49:14 (40 недель 3 дня 13 часов назад)
7700
Текст задания
После переноса конфигурации с Windows XP на Windows Server 2016 перестало работать прикрепление файлов к заявке.

Код отвечающий за этот функционал:
Процедура СканыFileIDНачалоВыбора(Элемент, СтандартнаяОбработка)
Попытка
СтандартнаяОбработка = Ложь;
// Выбрать файл на диске
ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогВыбораФайла.Фильтр = "Файлы типов (*.tif),(*.pdf),(*.doc),(*.xls),(*.jpg) |*.tif*;*.pdf;*.doc*;*.docx*;*.xls*;*.xlsx;*.jpg;*.jpeg";
ДиалогВыбораФайла.Заголовок = "Выберите файл";
ДиалогВыбораФайла.ПредварительныйПросмотр = Ложь;
ДиалогВыбораФайла.Расширение = "*";
ДиалогВыбораФайла.ИндексФильтра = 0;
Если ДиалогВыбораФайла.Выбрать() Тогда
ИмяФайла = СтрЗаменить(ДиалогВыбораФайла.ПолноеИмяФайла, ДиалогВыбораФайла.Каталог, "");
ВыбФайл = Новый Файл(ИмяФайла);
Год = ПолучитьГод();
РасширениеФайла = ?(Лев(Прав(ДиалогВыбораФайла.ПолноеИмяФайла, 4), 1) = ".", Прав(ДиалогВыбораФайла.ПолноеИмяФайла, 4), Прав(ДиалогВыбораФайла.ПолноеИмяФайла, 5));
Если ВыбФайл.Существует() Тогда
ВыбКаталог = Новый Файл(Константы.SavКаталогСканов.Получить() + "" + Год);
Если НЕ ВыбКаталог.Существует() Тогда
СоздатьКаталог(Константы.SavКаталогСканов.Получить() + "" + Год);
ВыбКаталог = Новый Файл(Константы.SavКаталогСканов.Получить() + "" + Год);
ВыбКаталог.УстановитьТолькоЧтение(Истина);
КонецЕсли;
СканФайл = Новый Файл(Константы.SavКаталогСканов.Получить() + "" + Год + "" + Строка(Ссылка.УникальныйИдентификатор()) + "-" + ?(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки < 10, "0","") + Строка(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки) + РасширениеФайла);
Если СканФайл.Существует() Тогда
СканФайл.УстановитьТолькоЧтение(Ложь);
КонецЕсли;
КопироватьФайл(ДиалогВыбораФайла.ПолноеИмяФайла, Константы.SavКаталогСканов.Получить() + "" + Год + "" + Строка(Ссылка.УникальныйИдентификатор()) + "-" + ?(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки < 10, "0","") + Строка(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки) + РасширениеФайла);
ЭлементыФормы.Сканы.ТекущаяСтрока.FileID = Строка(Ссылка.УникальныйИдентификатор()) + "-" + ?(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки < 10, "0","") + Строка(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки) + РасширениеФайла;
СканФайл = Новый Файл(Константы.SavКаталогСканов.Получить() + "" + Год + "" + Строка(Ссылка.УникальныйИдентификатор()) + "-" + ?(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки < 10, "0","") + Строка(ЭлементыФормы.Сканы.ТекущаяСтрока.НомерСтроки) + РасширениеФайла);
СканФайл.УстановитьТолькоЧтение(Истина);
Иначе
Сообщить("Файл не выбран, или отсутсвует");
КонецЕсли;
КонецЕсли;
Исключение
Сообщить("Ошибка прикрепления файла-скана");
КонецПопытки;
КонецПроцедуры


То есть я просто копирую на любую машину с 1С и Windows XP - все работает, на Windows 2016(и подозреваю что и на Windows 10) при попытке прикрепить файл 1С выдает ошибку - см. файл во вложении.
Доступ к базе предоставлю.

БИТ: Экспедирование 3.5 для Бухгалтерии предприятия, редакция 2.0 (2.0.30.8/3.5.5.11) - конфигурация
0
предыдущие ()все
Выбранные исполнители
Отклики
! новое событие